Eclipse 2020-06


Gå til bund
Gravatar #1 - arne_v
10. aug. 2020 22:46
Note: den kræver Java 11.

Java 8 er 6 år gammel, så det er vel OK at den kræver Java 11. Og hvis den havde fejlet under opstart med besked "Java 8 detected - minimum version is 11", så havde det været super fint. Men i.s.f får man lidt tilfældige fejl under installation af plugins. Ikke smart.

Jeg blev ramt ved at Java EE versionen startede fint under 8, C/C++ versionen startede fint under 8, men installation af C/C++ support i Java EE versionen fejlede under 8 - 11 er nødvendigt.
Gravatar #2 - arne_v
10. aug. 2020 22:48
#2

Og det er altså den Java som Eclipse selv bruger jeg snakker om.

Man kan bygge med og køre med alle mulige versioner.

Jeg har 6, 7, 8, 9, 11 og nyeste defineret.
Gravatar #3 - larsp
12. aug. 2020 12:05
Jeg har praktisk talt aldrig bemærket ændringer eller forbedringer efter Eclipse opgraderinger. Hvad laver de kære eclipse-udviklere egentlig udover at skabe afhængigheder til nye java versioner?

Det eneste var en unødvendig og grim launch toolbar der dukkede op for nogle år siden, men den kunne heldigvis fjernes.

Jeg bruger så kun Eclipse til C/C++. Men jeg er begyndt at forkaste opgraderinger. De gamle bugs bliver alligevel ikke løst og resten af programmet bliver bare værre og værre.
Gravatar #4 - arne_v
12. aug. 2020 12:22
#3

Det er mit indtryk at de gængse sprog som Java, C/C++, PHP etc. er i en form for maintenance status d.v.s. at de primært tilføjer support for nye features i sprogene og deres tool set.

De tilføjer nye sprog som f.eks. Rust.
Gå til top

Opret dig som bruger i dag

Det er gratis, og du binder dig ikke til noget.

Når du er oprettet som bruger, får du adgang til en lang række af sidens andre muligheder, såsom at udforme siden efter eget ønske og deltage i diskussionerne.

Opret Bruger Login